Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error Occured on Executing an SQL Statement
#1
Hi,

Since our upgrade to ASG 2018, one of our many environments is having an issue.
Users are getting an error message after a log out or re-connecting from a RDP session.
The error message is: "An Error Occured on executing an SQL statement".

More info:
- This environment is the largest we have at the moment (1,1 GB)
- Since upgrade to version 2018 (installed patch 2)
- Multiple users are impacted
- My team is working on another environment and nobody has this issue.
- Sometimes ASG freezes completely and needs to be killed via Task Manager (after getting this error of course)
- DB's are running on a SQL Geo Cluster (same Geo Cluster as always)
- See attachment for screenshots and log events
- Activated error log option, was disabled.

Thank you for your help!


Attached Files
.txt   eventlog1.txt (Size: 4.67 KB / Downloads: 82)
.png   asg_sql_error.png (Size: 9.4 KB / Downloads: 97)
.txt   eventlog2.txt (Size: 4.67 KB / Downloads: 87)
Reply
#2
Did you try to use DataOptimizer to shrink the size of your database? Also logs should be limited if possible.


You can set a higher Timeout (in Environment settings) - but for a single SQL statement 15 seconds should be enough.

How many objects do you have in your environment? The error happens when Properties are saved - DataOptimizer should be able to merge a lot of properties that have the same content.
Regards/Gruss
Oliver
Reply
#3
Data Optimizer seems to work, no error logs anymore since yesterday morning.
I've only enabled error logs for this issue, rest is disabled.

How can I see the total of objects in a environment?

Thank you!
Reply
#4
We have no statistics inside ASGRD - but with MS SQL Management Studio you could query it by using

SELECT count(*) FROM Items
Regards/Gruss
Oliver
Reply
#5
9444 Objects.
That's quite a lot, I guess?
Reply
#6
Hi,

After a while, this issue re-appeared.
As you suggested, I've applied the Data Optimizer (a couple of times) and increased the connection timeout to 60 seconds.

Is there anything else that I can try?

Thank you
Reply
#7
Can you try to upgrade to Patch3 - we did some code changes to prevent this type of error...
Regards/Gruss
Oliver
Reply
#8
Has anybody the error who is using the database or just one person? On a specific object or for all?
Regards/Gruss
Oliver
Reply
#9
Will do!

Some colleagues are having this issue, but only in one environment (we have more than 10 environments).
And I think it's for all objects. It's hard to track it because this environment has 9444 objects.
Reply




Users browsing this thread: 2 Guest(s)