Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unknown Error during connection (login ASG Remote Desktop)
#1
The database connection times out from locations running their client in remote locations, e.g. Server here in Europe and Clients are in China.

Login Windows is showing up, but after clicking Login, sometimes "Not Respondig" is showing up, sometimes "ASG-Remote Desktop 2015 has stopped working" and seldom it works.

ASG Remote Desktop Version: 2015 Patch Level 6 (V 8.0.4872.0)

SQL Server is located in Europe.
Ping time to SQL Server from Europe: < 1ms
Ping time to SQL Server from China: > 230ms

Thanks for your support
Kind regards
Roland
Reply
#2
You should try to set a larger timeout for your database environment.

In Login dialog - press "..." - edit your current environment - activate "Configure advanced settings" - Next => Then try to set a timeout of at least 30 seconds, perhaps more - the whole data is loaded at startup and I think you are running in a timeout...
Regards/Gruss
Oliver
Reply
#3
Hello Oliver, thanks for your answer. We've already set the timeout to 300 seconds and it's still not working. This morning people in China (afternoon in China) did some try, out of 5 tries 2 worked, 3 not. Even the parameter is set to 300 second they can click again the "Login" button after 1 minute. For tests we replicated our Database to a DB located at China. With this replication it works fine, but if possible we would linke to use the DB located in Europe, because we can only have an SQL Express Ed. at China and SQL merge Replication is not possible.

With the old ASG 2012 Version it worked fine. Since we use the 2015 Version the problem appeared.

Kind regards
Roland
Reply
#4
Once you can check to minimize traffic - deactivate all logs and clean all logs - perhaps that can help?
Regards/Gruss
Oliver
Reply
#5
We have the same issues between our Netherlands and US office. There is a round trip latency of 175ms between offices. I too have made the change in timeout on the connection to 300secs but it doesn't try anywhere that long it seems. Where can I check to see what is happening?
Reply
#6
Okk - there are perhaps some options you can try...

First is to check th size of the logs - minimize your logs by deactivating them or set a small "max amount" or "max days" value in Options=>Logs...

Then you can try to delete "Properties" you don't need - in version 2012 all properties were saved for each connection. So it doesn't matter if you used all protocols or not all data was saved. In version 2015 you can choose "Roles" on folder/connection level - if you don't use ICA, VNC, or something else you can deactivate these roles. To delete the data for these objects you have to use MultiEdit - there are the possibility to "remove the roles" and to "delete the data" stored for these protocols. If you use always the same properties for a protocol you can specify on a folder and choose to inherit these values to all childs... (check if you can delete the properties with MultiEdit for all sub objects) - if you do this, you can reduce the data that is stored - and of course loaded at startup - to a minimum. And it should be easier to manage also. The migration copied all data to all objects. We plan to implement some kind of "data optimizer" for the future that will check this automatically and ask the user to remove not necessary properties automatically...


To see which command breaks the startup process you should start "SQL Server Profile" inside the "Microsoft SQL Management Studio" - if you run the profiler on your database instance and database you could see what happens - if you are not aware of this tool you could send me the results and I have a look at it...
Regards/Gruss
Oliver
Reply
#7
We did all the points you recommended in your answers. We "deleted" all logs, removed unused Roles, inherited all possible stuff. But unfortunately for our Chinese colleagues it is still not working and they cannot use the ASG Remote Desktop any more. Is it somehow possible to go back to the old 2012 Version?
Reply
#8
You can use 2012 and 2015 side by side - you can't downgrade the datasource from 2015 - but the upgrade process didn't change your old data so you still can use it
Regards/Gruss
Oliver
Reply
#9
We installed the old ASG 2012 Version in China and tried to connect to the Database used as well in 2015 Version.
An Error shows up trying to start the Environment: visionapp.vCCCommonLib.ExceptionHandler.vCCException: Could not find stored procedure 'vCCSelectAllConfigValues'.
In the Database for ASG 2015 there is no stored procedure called vCCSelectAllConfigValues. When I have a look into the DB of Version 2012 there are a lot of stored procedures beginning with vCC*, in 2015 not. So how can we use ASG 2012 and 2015 in mixed mode?
Reply
#10
You can't use 2 different main releases in mixed mode - you can migrate your data from 2012 to 2015

If you want to use version 2012 you need to use the old data source for that version
Regards/Gruss
Oliver
Reply
#11
(14-07-2015, 07:55 AM)DevOma Wrote: You can't use 2 different main releases in mixed mode - you can migrate your data from 2012 to 2015

If you want to use version 2012 you need to use the old data source for that version

I'm really sorry coming up again with this topic.

It's not an option for my company to use an old 2012 version.

We have this problem only with one client located to another location where the database is stored.

The ping to the SQL server from his pc shows 25ms. So not really that slow.

Are there any other recommendations to use?
Reply
#12
Which problem do you have? Currently I do not know how we can help you?!?
Regards/Gruss
Oliver
Reply
#13
Did you try deactivating all logs - higher timeout in environment connection settings?!? Some miore details... What error do you get? Which version do you use?
Regards/Gruss
Oliver
Reply
#14
(31-07-2018, 11:48 AM)DevOma Wrote: Did you try deactivating all logs - higher timeout in environment connection settings?!? Some miore details... What error do you get? Which version do you use?

Sorry for not that much information.


ASG Version: ASG 2017

SQL Server Details: SQL 2008 R2
MDF File: 68 MB
Log File: 1 MB

Connection Timeout: 3000

There is no error you can see in the UI. You click on the "Connect" button ==> shows the circle with "no responding" when you click again on the login window. After a while (30 seconds) it just shows the login window again. Nothing else.

In the settings of the administrator user I have disabled the "Default Values" the "Offline (Automatic save offline data when ending application in database mode" without luck. No differences if this is enabled or disabled.

No SQL-Profiler running yet because I do not have access to the SQL Server. I have to speak to the SQL Server Admin.

Additionally information: The test connection button within the connection setting works fine when trying the dedicated SQL user (sql_asg in our case)

Edited: I do now have the SQL-Profiler files. If needed I can them upload or send to you. Please let me know.
Reply
#15
Ok - so I guess it is not the same issue as the thread you posted in...

I know that in previous versions we had some failing login attemps that do not report any errors... first you have to check if there is any log in the Windows Application Event Log - if yes would be great to know :-)
If not - what is different for that client that do not work? Not joined to the same domain, network, ...?!?
Regards/Gruss
Oliver
Reply




Users browsing this thread: 1 Guest(s)